Sign Up! Login: Password: New User? Forgot? Support
Code 
 
 
Forums 
Forums : Multimedia > Video Box
Leuse (Applicant) 11/13/2010 10:49 AM EST : RE: Video Box v3

Leuse
Posts: 112

0
Like

0
Dislike

Mottie,

Have been trying use v3 method to post on our guild site.  I can get the first two drop down menus to work, but the third menu just shows "<- select" with no other options.

I posted your sample code in to see if I was jacking it up as I was editing, but have the same problem even after a direct copy-paste.

Any thoughts?

Thanks!

(btw, v2 works like a charm!)
TopBottom

Mottie (SuperAdmin) 11/13/2010 1:55 PM EST : RE: Video Box v3
ACK!
Mottie
Posts: 3883

0
Like

0
Dislike

Hi Leuse!

I just tested the code I have and it still appears to be working just fine. I think the problem might be that when you add the code to a free form text/HTML widget, make sure the editor is in Raw mode (upper right corner) before you paste it in and leave it in that mode when you save. If you go post content in another widget, you might have to switch it back out of raw mode to see the Wysiwyg editor tools.
Characters: Mottie Motty Mortie Ooshiny Mot Fudgems
TopBottom

Leuse (Applicant) 11/14/2010 8:33 AM EST : RE: Video Box v3

Leuse
Posts: 112

0
Like

0
Dislike

Mottie,

Thanks.  That was the issue, it works great now. 

Thanks for the work you put into this site, it's been very helpful for someone who never messed with html previously.

Leuse
TopBottom

pcolapat (Member) 9/20/2011 4:38 PM EST : RE: Video Box v3
pcolapat
Posts: 1124

0
Like

0
Dislike

Leuse said:
Mottie,

Have been trying use v3 method to post on our guild site.  I can get the first two drop down menus to work, but the third menu just shows "<- select" with no other options.

I posted your sample code in to see if I was jacking it up as I was editing, but have the same problem even after a direct copy-paste.

Any thoughts?

Thanks!

(btw, v2 works like a charm!)


I have been having the same issue as this poster, but so far I am unable to resolve it. I made sure I was in RAW, I just copied and pasted your code directly from the site, made no changes to it, and I get the "<-select" for the video option. On your site it seems to work like it should. I just can't get it sorted out. The site i am testing the video box is here http://www.guildportal.com/Guild.aspx?GuildID=374169&TabID=3141745

I wish he had explained exactly how he had resolved his issue. I am pretty sure I am doing this correctly, but it is just not wanting to work for me. Please help
Characters: pcolapat
TopBottom

Mottie (SuperAdmin) 9/20/2011 6:41 PM EST : RE: Video Box v3
ACK!
Mottie
Posts: 3883

0
Like

0
Dislike

Hi pcolapat!

The problem is an error from another widget is stopping the video box code from running... it has something to do with twitter. The error I am seeing is:

TWTR is not defined... from this line: new TWTR.Widget({

Maybe if you move this line to a different widget that is further up or further left from the one you have it in now.
<script src="http://widgets.twimg.com/j/2/widget.js"></script>
it might fix the error problem, but I can't guarantee it 
Characters: Mottie Motty Mortie Ooshiny Mot Fudgems
TopBottom

pcolapat (Member) 9/20/2011 11:25 PM EST : RE: Video Box v3
pcolapat
Posts: 1124

0
Like

0
Dislike

Mottie said:
Hi pcolapat!

The problem is an error from another widget is stopping the video box code from running... it has something to do with twitter. The error I am seeing is:

TWTR is not defined... from this line: new TWTR.Widget({

Maybe if you move this line to a different widget that is further up or further left from the one you have it in now.
<script src="http://widgets.twimg.com/j/2/widget.js"></script>
it might fix the error problem, but I can't guarantee it 


Well I deleted the entire twitter widget, recreated the FreeformHTML widget and reentered the code, saved it. and still doesn't work. Got some big plans for that media box, I really wish I could get it to work.
Characters: pcolapat
TopBottom

Mottie (SuperAdmin) 9/21/2011 12:10 AM EST : RE: Video Box v3
ACK!
Mottie
Posts: 3883

0
Like

0
Dislike

Ahhh ok I see the problem... you have a second copy of the video box in the custom javascript area (Control Panel > Custom HTML & Script > Custom Javascript/jQuery > Document Ready Function... just remove it all from there - it's causing errors.
Characters: Mottie Motty Mortie Ooshiny Mot Fudgems
TopBottom

pcolapat (Member) 9/21/2011 2:10 AM EST : RE: Video Box v3
pcolapat
Posts: 1124

0
Like

0
Dislike

Mottie said:
Ahhh ok I see the problem... you have a second copy of the video box in the custom javascript area (Control Panel > Custom HTML & Script > Custom Javascript/jQuery > Document Ready Function... just remove it all from there - it's causing errors.


Okay, did that and still no success. So I created a brand new guild website just to see what would happen if tried to put this code in a guild that has never been messed with. It does the same thing. If you could apply to this site i can make you an admin on it so you can see what I have done. It isn't my paid site, just a site I made specifically to resolve this problem. Here is the link Media Box the Guild

The only thing I did was this, create the guild, control panel, pages, home, html/freeform, raw script, paste the code directly from this thread to that box, save. That is it. It looks great, but it don't wanna work. I am sure I am doing something wrong. Just don't know what it is.
Characters: pcolapat
TopBottom

Mottie (SuperAdmin) 9/21/2011 9:02 AM EST : RE: Video Box v3
ACK!
Mottie
Posts: 3883

0
Like

0
Dislike

Hi pcolapat!

DOH, I apologize for not looking more closely at the code. Apparently a forum filter has removed a bunch of the common javascript functions one being called "get element by id" (without spaces). So a bunch of the code is now incomplete.

I tell you what, if you have time, I wrote this code way back when before I knew jQuery so I think I'll just rewrite it and turn it into a mod to make it easier to deal with. Give it a day or so for me to make it and for it to get approved 
Characters: Mottie Motty Mortie Ooshiny Mot Fudgems
TopBottom

Mottie (SuperAdmin) 9/21/2011 9:33 AM EST : RE: Video Box v3
ACK!
Mottie
Posts: 3883

0
Like

0
Dislike

Oh, and if you can't wait... the easiest solution would be to go to this post, then hit the reply & quote button... the code shows up properly in this case, so just copy it from there.
Characters: Mottie Motty Mortie Ooshiny Mot Fudgems
TopBottom

 
 
Key 
New posts No new posts
New posts ( popular ) No new posts ( popular )
New posts ( sticky ) No new posts ( sticky )
New posts ( locked ) No new posts ( locked )
 
 
Who's Online 
There are   members online.
 
 
So-and-so has logged on!
%title%
%message%