Sign Up! Login: Password: New User? Forgot? Support
Top Mods!
Wowhead Search
by sonofsamedi
Digital Clock
by Wolfar15
Admin Forums
Welcome to the GuildPortal Help Community! These forums are for admin-to-admin help.
Available Forums
Forums : Pimp My Site! > Adding a Welcome Screen (Splash Page) to your website
Mottie (MVP) 9/4/2008 4:40 AM EST : RE: Adding a Welcome Screen (Splash Page) to your web...
GuildPortal MVP
Mottie
Posts: 3884
Zomgawsh Poster

Well leave the positioning in the CSS, but remove the background image from there.
TopBottom

539934927_Inactive (New Admin) 9/4/2008 4:45 AM EST : RE: Adding a Welcome Screen (Splash Page) to your web...

539934927_Inactive
Posts: 20
Becoming Adept!

Sorry if I'm not following. Where 'there' are we talking about? Haha, I don't think I know enough for this! I shouldn't have tried to make something stylish.

If I use the

#ctl00_ContentPlaceHolder1_PageContainer { position: relative; top: -5px; overflow: hidden; background: url("http://www.axiomfiles.com/Files/277894/banner.jpg") no-repeat top center; }

and turn it into 

.BannerArea { position: relative; top: -5px; overflow: hidden; background: url("http://www.axiomfiles.com/Files/277894/banner.jpg") no-repeat top center; }

It moves it and then dosn't show under the status bar or buttons right, is there some way to remove the banner when just the welcome screne is showing? I didn't do anything special from your example at the beginning, just replaced the url's. It seems to be showing through for some reason even though I only tell it to show the icon and the background. Is there some line of code I could put in that welcome html or in the banner area edit box that would do it? Or make it a .BannerArea and still do the same effect as the contentplaceholder?


*EDIT*

PEEEEEERRRRRRRFFFFFEEEEECCCCTTTTT!!!!!!
Mottie really is the best! Your reputation only grows! THANKS A TON!
TopBottom

Mottie (MVP) 9/4/2008 4:58 AM EST : RE: Adding a Welcome Screen (Splash Page) to your web...
GuildPortal MVP
Mottie
Posts: 3884
Zomgawsh Poster

I still can't tell what alignment issue you're having LOL

Anyway the reason this is a problem is because the welcome screen uses the #ctl00_ContentPlaceHolder1_PageContainer and you added a background image to it...

Here is a simple fix then... edit your welcome screen box content and add the text in red to the CSS near the bottom (make sure it's the CSS with the "display:inline"):
#ctl00_ContentPlaceHolder1_PageContainer { display:inline; background: #000 url(); }
TopBottom

Mottie (MVP) 4/10/2009 12:22 AM EST : RE: Adding a Welcome Screen (Splash Page) to your web...
GuildPortal MVP
Mottie
Posts: 3884
Zomgawsh Poster

Updated the code with a meta tag that will automatically redirect your browser to your home page after so many seconds... so you don't need to click the enter button to get there anymore.
TopBottom

FloydCheetah (New Admin) 5/14/2009 2:49 PM EST : RE: Adding a Welcome Screen (Splash Page) to your web...

FloydCheetah
Posts: 128
Posts With Wolves

Hello!

I've been messing with this for hours and it's just not showing up.  I'm such a newb at this.  This is the code I entered, any suggestions? Did I miss something obvious?

<style type="text/css">
body { display:none; }
</style>

<div id="splashBox">

<div align=center>
<div style="height:200px;"></div>
Welcome $block[username] to<br>
<img src="http://www.axiomfiles.com/Images/Dynamic/313421.png">
<div style="height:100px;"></div>
<a href="http://www.guildportal.com/Guild.aspx?GuildID=313421&TabID=2627618">
<img src="http://i201.photobucket.com/albums/aa236/Mottie1/testsite/forums/entersite.gif">
</a>
</div>
<meta http-equiv="refresh" content="10; url= http://www.guildportal.com/Guild.aspx?GuildID=313421&TabID=2627618">

<style type="text/css">
.StateBar, .BannerArea, .TabBar, .PageFooter, div.ContentBoxBody, .ContentBoxTitle, input  { display:none; }
body { background: #333333 url(http://www.axiomfiles.com/images/ThemeGfx/backgroundblackstone.jpg); color:#ffffff; display:inline; }
img, img a { border:0px; }
</style>
</div>

<script type="text/javascript">
$(document).ready(function() {
var a = document.getElementById('splashBox').innerHTML;
document.getElementById('ctl00_ContentPlaceHolder1_PageContainer').innerHTML = a;
});
</script>

Thanks,

Shannon 
ssilver1215@gmail.com 



TopBottom

Mottie (MVP) 5/14/2009 6:30 PM EST : RE: Adding a Welcome Screen (Splash Page) to your web...
GuildPortal MVP
Mottie
Posts: 3884
Zomgawsh Poster

Hi FloydCheetah!

It looks like it's working... you need to remove the TabID from the URL to get to it... here is the link to your Welcome page:


And if you wait 10 seconds, it'll redirect you to your Home page.
TopBottom

RangerAimee (Guild Admin) 4/17/2010 8:27 PM EST : RE: Adding a Welcome Screen (Splash Page) to your web...
RangerAimee
Posts: 140
Posts With Wolves

I'm not sure how active this is anymore but here I go.

Everything worked out great when I tried this. The only problem is if I try to edit the background so that its all white the whole thing just freezes on the same page. This is what I have so far _> HERE 

My question is, how do I make everything white?

Thanks in advance.
  
TopBottom

Mottie (MVP) 4/17/2010 10:09 PM EST : RE: Adding a Welcome Screen (Splash Page) to your web...
GuildPortal MVP
Mottie
Posts: 3884
Zomgawsh Poster

Hi RangerAimee!

I followed your link and found a page that was pretty much all white except for the images (even the text at the top was white). So I'm not quite sure what you mean by making everything white and can you tell me what exactly you are trying to change in the background when it freezes.
TopBottom

RangerAimee (Guild Admin) 4/18/2010 5:31 PM EST : RE: Adding a Welcome Screen (Splash Page) to your web...
RangerAimee
Posts: 140
Posts With Wolves

The reason is that the only way I could get it to all match and be one solid color I had to modify the overall theme of the site. By making it white the welcome screen would be white. So that has all been fixed and I'll leave it like that. Now the only problem is on certain computers nothing shows up at all, but its very rare so I think it's just there computers. Sorry I didn't update sooner, I just tinkered on my own with older things I learned. But if I change the main theme to a diffrent color there will be another colored box on the welcome screen surronding the main graphics. It's ugly. lol So white will be it's new face.

Thank you so much for your time!
  
TopBottom

Kërby (New Admin) 11/20/2010 4:43 PM EST : RE: Adding a Welcome Screen (Splash Page) to your web...
Kërby
Posts: 6
Getting Started!

ok im not sure if i missing something here or not, but i have tried both options to remove/hide the "welcome" page that i created to make the splash page but alas it still comes up.... grrr help please.

http://phxrising.guildportal.com/Guild.aspx?GuildID=375846&TabID=3157607
TopBottom

Admins Online
There are   members online.
So-and-so has logged on!
%title%
%message%