Sign Up! Login: Password: New User? Forgot? Support
Top Mods!
Wowhead Search
by sonofsamedi
Digital Clock
by Wolfar15
Admin Forums
Welcome to the GuildPortal Help Community! These forums are for admin-to-admin help.
Available Forums
Forums : Pimp My Site! > What's going with GP?
Mottie (MVP) 1/16/2009 3:35 AM EST : RE: What's going with GP?
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

I posted this in another thread, but I'll repost it here since there are so many threads... and I just noticed Azbulldog posted it as the first reply... sorry about the repeat.

How to get to your control panel

This only works if you are set as an admin and currently logged into your site.
  1. You need to first log into your site...
  2. Make a new tab/window
  3. Copy the link below and paste it into the new tab browser address bar
  4. Before you load the page (hit enter), replace the numbers in red with your GuildID (see the next step).

    http://guildportal.com/CExplorer/cexpFrame.aspx?Group=111111&PageOption=CExplorerHome

  5. To find your GuildID, go back to your site tab/page and then look in your browser address bar, it should look something like this:

    http://guildportal.com/Guild.aspx?GuildID=111111&TabID=2222222

    The GuildID is in red. Copy it and switch back to your new tab and then replace the numbers.
TopBottom

chefricochet (Guild Admin) 1/16/2009 4:45 AM EST : RE: What's going with GP?
chefricochet
Posts: 208
Fingers of Fury!

 Thanks Motie, but it doesn't work! The page you posted, told me to log out, and back in, Which I did. Im still locked out!

Laggin
If you love something, set it free! If it doesn't come back; hunt it down, and kill it!
TopBottom

Grace Diamond (Guild Admin) 1/16/2009 6:50 AM EST : RE: What's going with GP?
Grace Diamond
Posts: 197
Posts With Wolves

I'm just a bit more concerned that today's Friday, which means if it's not sorted today then it'll be like this all weekend...

lol I'd just resubscribed too last week for another 6 months, so I hope they sort this otherwise I'll have just wasted $45.

TopBottom

IceHeart. (Guild Admin) 1/16/2009 7:08 AM EST : RE: What's going with GP?
IceHeart.
Posts: 110
Posts With Wolves

Here's 2 ideas for you, chef, that *might* help.. but I cannot be sure..

The login/control panel functionality within the guildpage itself, in particular setting up the UserID cookies,  is *also* managed with jQuery, which means, its about as broke as everything else, -within the Guild pages-.
However, the code on GP's home page appears to be correct.

1- Try logging in and out  -first- at the GP home page to reset your cookies, -then- opening the Control Panel by using the direct links as posted above by Mottie.

2-  IE and FF react differently to some of these pages, (as usual) with FireFox being usually a little more forgiving than IE. If by chance, you're using IE, try FF (or maybe the other way around)


TopBottom

chefricochet (Guild Admin) 1/16/2009 8:31 AM EST : RE: What's going with GP?
chefricochet
Posts: 208
Fingers of Fury!

 Thanks ice, I tried it, and no go! I use FF, and also tried using IE, thanks

Laggin
If you love something, set it free! If it doesn't come back; hunt it down, and kill it!
TopBottom

IceHeart. (Guild Admin) 1/16/2009 9:02 AM EST : RE: What's going with GP?
IceHeart.
Posts: 110
Posts With Wolves

Chef,
I was poking around in your sites, and notice that you have quite a few different guilds.. 6 or 7? and that seems to be part of the problem...

If I follow the 1st link on your profile, to your 'theoretically'
 Chainmail, Guild ID 265895 (khyber)    <here> 

I end up at what I assume is your main splash page... however, the 'enter' link actually redirects me to a different guild altogether,  your
 Chainmail Thelanis  Guild ID 251729  (thelanis)

.. by doing that, I lose identification of my user, and tells me I'm not logged in  (don't ask me why- its all messed up these days, hehe).. which is likely whats happening to you.

This also happens with your

Chainmail, Guild ID 265890 (argonessen) , where the enter button is actually linked to your thelanis guild (251792) as well.

Also, your chanimail domain seems to be connected to a different guild but redirects to thelanis?

If I connect 'directly' to your site in thelanis by avoiding the chainmail domain etc, and linking specifically , say:

http://www.guildportal.com/Guild.aspx?GuildID=251729&TabID=2116509

then I can correctly keep my user, so I'm thinking you should then be able to access your Control panel there.

Now, I cant obviously access any other tabs in your 'splash' guilds (265890 and 265895), but maybe you yourself can if you know the TabIds local to those, or maybe able to fire off the Control panel directly on those guilds as well.

On a separate note, I also had some trouble with our domain name beingincorrectly linked some 6 months ago. Had to send trouble ticket etc... So my guess its in your case u may have 2 troubles rolled into one...

Hope that helps..


P.S: Pretty cool music!  I may steal a couple tracks

TopBottom

Mottie (MVP) 1/17/2009 12:12 AM EST : RE: What's going with GP?
GuildPortal MVP
Mottie
Posts: 3883
Zomgawsh Poster

Well I'm frustrated now...

The new jQuery box is going to be a pain in my a** because now I have to go back and rewrite EVERYTHING that uses jQuery, including the instructions... I'm considering ditching jQuery altogether or maybe just saying screw it all and find some other kind of project to spend my time on.


TopBottom

IceHeart. (Guild Admin) 1/17/2009 7:05 AM EST : RE: What's going with GP?
IceHeart.
Posts: 110
Posts With Wolves

Mottie said:
Well I'm frustrated now...

The new jQuery box is going to be a pain in my a** because now I have to go back and rewrite EVERYTHING that uses jQuery, including the instructions...



Totally agree there. GP devs, honestly, don't know what you guys are smoking on this one, but it must be reeeeeally goood, because you totally disconnected from reality on this one. :-P

The end of the page is NOT the location for placing the main jQuery call, and it's not a solution for 'certain browser' problems. A simple glance at the jQuery documentation tells you this.

The jQuery library should be placed at the top of the page, preferably at the <head>.. only the calls to $.ready should be placed at the end, and this is only a convention, as jQuery itself queues different calls to #.ready and executes them only after validating that the document has been completely loaded. and this has been already tested cross browser!!! there's no need to reinvent the wheel here.

The 'new 'custom jQquery code window does not make sense, as it is centralized, and different pages have different calls. It doesnt help me, and I'm sure it doesn't help a whole lot of people out there. If you really do want to do something like this, then it should be done at the page level. perhaps as an addition to the 'Display options' So every page has something separate.  But there is really no need to do this.

You guys are throwing the baby out with the dirty water on this one..  Lets get back to normal and try to find another solution here...
(not that I ever see you in these forums but every blue moon , but , hey.. if you come and post here, there's plenty of knowledge among your users too... )





TopBottom

IceHeart. (Guild Admin) 1/19/2009 7:27 AM EST : RE: What's going with GP?
IceHeart.
Posts: 110
Posts With Wolves

I see that the JQuery and related 'core' scripts are now correctly located at the head of the pages.. I'm going to remove the forced script calls and see how my site works now...

Removed the double script calls and the site appears to be back to working correctly. Other than a missing box around the State bar, which is probably a bug on my own custom CSS.

Thanks Aaron / Devs for listening to the cries... 



TopBottom

IceHeart. (Guild Admin) 1/19/2009 8:24 AM EST : RE: What's going with GP?
IceHeart.
Posts: 110
Posts With Wolves

As noted by Mottie <here>

Mottie said:
The hotfix today has fixed most of the problems, but one line of code was left out.
<script src="dtips.js" type="text/javascript"></script>
Thetooltips are gone! This can't be added into the header since the scriptrequires the tooltip box (which is still in place) to be defined beforethe code. So, add the above line into your FOOTER... the header isstill above the tooltip box and will produce an error.



Aaron / GP Devs: As per Dynamic's drive instructions, the call to the dtips.js  script should be placed immediately after the  <div id="dhtmltooltip"></div>
which is currently the 1st element within the <body> tag, even above the <form>, since otherwise even GP's own dhtml tooltips for Control panel etc, won't work....
TopBottom

Admins Online
There are   members online.
So-and-so has logged on!
%title%
%message%