Sign Up! Login: Password: New User? Forgot? Support
Top Mods!
Wowhead Search
by sonofsamedi
Digital Clock
by Wolfar15
Admin Forums
Welcome to the GuildPortal Help Community! These forums are for admin-to-admin help.
Available Forums
Cosmic Titan (New Admin) 2/2/2005 3:00 PM EST : Getting Guildportal Lock Ups

Cosmic Titan
Posts: 5580
Zomgawsh Poster

I'm having toubles with my Guildportal web site that started around three days ago.  As site admin, when I edit certain parts of the site, a child window spawns that has a wysiwyg editor similar to the one most see when adding a forum post.

I edit what I need to and click save.  The material gets saved but then the child window and my guild site lock up ("program is not responding").  I have to end IE with the task manager.  When I restart it, the changes I made have taken place and the site works fine, at least until I edit something else.

This doesn't happen when I add posts and such.  Those don't spawn child windows.  It does happen everytime I use the wysiwyg editor in a child window, though.

I'm open to suggestions.  This isn't a Guildportal problem because it doesn't happen if I use my laptop or another computer in the house.  It's my main computer only and it happens regardless of whether I use my XP login or my wife's.

Any suggestions of things I might try?
TopBottom

Aaron Lewis (Blue Collar) 2/3/2005 3:54 AM EST : RE: Getting Guildportal Lock Ups
GuildPortal Dev
Aaron Lewis
Posts: 1978
Zomgawsh Poster

Heya Cosmic --

I did a little searching and asking around on the WYSIWYG vendor's homepage (I'm still not totally convinced it's not related toGuildPortal..) and below is what they had to say about it.  I'mnot sure if what they're suspecting the problem to be is actually theproblem in your case, especially since it's such a recent problem:

I have seen IE6 behave like this whenever a pop-up is opened (evenopening a link in a new window - using right click - causes this) Whenopening/closing  browser windows, IE seems to do a lot ofunnecessary resource allocation/de-allocation (and as far as i cantell/guess ... it also re-examines the cache, which causes theprocessor to spike) - this is the cause of the lockup. If users do notclick anything while IE is opening/closing one of it's windows (for aslong as 5 minutes), almost always it becomes responsive again ... Clicking on the window seems to seal the browser window's fate...
Aaron Lewis, GuildPortal.com
TopBottom

Cosmic Titan (New Admin) 2/3/2005 4:37 AM EST : RE: Getting Guildportal Lock Ups

Cosmic Titan
Posts: 5580
Zomgawsh Poster

I suspect that some of what the vendor says applies to me.  Strangely, though, this isn't happening to everyone and it only happens on the main computer I use.  If I use a different computer, this does not occur.

I appreciate your efforts to help me figure this out.  I do think this is related to the new WYSIWYG editor, just not sure why only my newest computer is having problems.  Can you provide a link to the vendor's site so that I might look through their forums?  In addition, here is more information to aid in diagnozing this.

* This started some time around Jan. 29.  I did not install any new software prior to noting the problem.
* Even when not editing in a pop-up window, there is a lag after making a change before my links work.  So, I write an email message in Guildportal, for example, click send, and the message is sent, I cannot click another link for a few seconds (I don't get the "hand" on hover).  This has only occured since the new WYSIWYG editor went live.
* I have deleted my cache and cookies.  I've run three different spyware detectors and deleted several programs that add onto IE.  No effect.
* This occurs whether any other software is running or not.
* It only occurs when the editing is done in a pop up window, such as the free form html editor and only happens with the WYSIWYG editor.  Non WYSIWIG pop up windows, like the Events Editor do not cause this.

System Specs:

Windows XP
AMD 2100 chipset
Newest Nvidia drivers on a GeForce Ti4600
1 gig of RAM
using newest version of IE

Thanks again for the help and please send along the vendor's forum link if possible.  Also, are there any other pages where a guest could spawn a pop-up window with the editor?  That would narrow down whether it is that particular editor or not.
TopBottom

Aaron Lewis (Blue Collar) 2/3/2005 4:44 AM EST : RE: Getting Guildportal Lock Ups
GuildPortal Dev
Aaron Lewis
Posts: 1978
Zomgawsh Poster

You bet!

The forums are here.
Aaron Lewis, GuildPortal.com
TopBottom

Cosmic Titan (New Admin) 2/6/2005 2:36 AM EST : RE: Getting Guildportal Lock Ups

Cosmic Titan
Posts: 5580
Zomgawsh Poster

Still having problems with this.  Narrowed it down to the FreeTextBox editor but can't figure out what's causing the lock-ups.  Nice to know I'm not the only one experiencing problems, though.
TopBottom

Aaron Lewis (Blue Collar) 2/6/2005 9:35 AM EST : RE: Getting Guildportal Lock Ups
GuildPortal Dev
Aaron Lewis
Posts: 1978
Zomgawsh Poster

As a kind of interim thing, could you try opening the editor fromwithin the "Site Pages" area of the control panel directly, instead offrom the guild pages?  I know it should affect the outcome, sinceit launches the same window in the end anyway, but... Well, this wholething is odd.
Aaron Lewis, GuildPortal.com
TopBottom

537122981_Inactive (New Admin) 2/7/2005 3:37 AM EST : RE: Getting Guildportal Lock Ups

537122981_Inactive
Posts: 351
Fingers of Fury!

name="4704856">

GP is locking up forme lately and it cant be just me. I have 3 comps at home and GP locks up on all of them yet i can serf the web and it won tlock up. Is this just me now?

TopBottom

Aaron Lewis (Blue Collar) 2/7/2005 3:58 AM EST : RE: Getting Guildportal Lock Ups
GuildPortal Dev
Aaron Lewis
Posts: 1978
Zomgawsh Poster

Crowd -- is this only when using a WYSIWYG editor, after making changes?
Aaron Lewis, GuildPortal.com
TopBottom

Cosmic Titan (New Admin) 2/7/2005 5:01 PM EST : RE: Getting Guildportal Lock Ups

Cosmic Titan
Posts: 5580
Zomgawsh Poster

As a kind of interim thing, could you try opening the editor from within the "Site Pages" area of the control panel directly, instead of from the guild pages?  I know it should affect the outcome, since it launches the same window in the end anyway, but... Well, this whole thing is odd.


I didn't think that would work, Aaron, and testing it proved it.  It doesn't matter where you access the editor from.  If it opens in a popup window, it locks up all IE windows when you click [save].

This doesn't happen with Firefox but many IE features don't work properly with Firefox, so I'm now having to use a combination of the two.  Email, for instance, displays as html code in Firefox when you reply to someone.  Also, the image dialog box doesn't display properly when using the FreeTextBox editor with Firefox.  So, I'm still searching for the reason why FreeTextBox is locking up IE for me when in a popup window.

It seems to only happen to certain computers and I'm not sure why.  I just upgraded to Windows SP2 and upgraded Java but that didn't fix the problem.

FreeTextBox seems to use "asp.net".  Is there some end user software that I might be able to upgrade to and see if that fixes the problem?
TopBottom

Aaron Lewis (Blue Collar) 2/8/2005 4:16 AM EST : RE: Getting Guildportal Lock Ups
GuildPortal Dev
Aaron Lewis
Posts: 1978
Zomgawsh Poster

I figured that'd be the case too, but since I can't reproduce it here,I have to send anyone experiencing it down the same path I'd use tofigure out the behavior.  

Nah, ASP.Net is just the web layer of the .Net framework, and GP isbased off of that, too.  Nothing much you can do on the clientside to fix a bug in the server-side code (which is sure to be the casehere).  Still harping on the vendor.
Aaron Lewis, GuildPortal.com
TopBottom

Admins Online
There are   members online.
So-and-so has logged on!
%title%
%message%