Sign Up! Login: Password: New User? Forgot? Support
Top Mods!
Wowhead Search
by sonofsamedi
Digital Clock
by Wolfar15
Admin Forums
Welcome to the GuildPortal Help Community! These forums are for admin-to-admin help.
Available Forums
Forums : Pimp My Site! > How can I get the Gallery widget to use all the picture files loaded therein?
Liberty Rose (New Admin) 4/16/2010 8:47 PM EST : How can I get the Gallery widget to use all the pictu...
Liberty Rose
Posts: 1766
Zomgawsh Poster

I started this topic in the General Help forum, but, perhaps, this is the better forum in which to ask for advice?

I have suspected for some time that the algorithm for the rotating gallery widget is not actually random.  It only uses a certain number of the images most recently posted to the gallery.

Recently I did the following experiment.  (I was actually hoping to get two separate gallery widgets going on the home page, but that's apparently a Wish List feature that has no real connection to this problem.)  I deleted all the images (40+) that were in my gallery.  I recreated the gallery, loading in about 30 images.  (They are all a standard size, about 300 pixels high by 230 wide, not that I expect that matters.)  Then I created a  second gallery, loading in 10 images.

Then I sat back with my tally sheet to watch the "random" appearance of images on my front page.  As it happens, all 10 of the 2nd gallery's images are used "randomly"... and the last 5 images loaded into the 1st gallery are used "randomly".  None of the other images in the 1st gallery put in an appearance at all over the course of several hours.

At the same time, I introduced the static "random image" widget.  It does not seem to be constrained by the "last entered" = "gets used" algorithm, as it certainly showed over time, when I'd reload my screen, a couple of the 25 images that the random gallery refuses to use.  
I do admit that I do not have the patience to test the static widget intensively. {smile}  

So... is this a known bug in the algorithm?  Or is there something I can do to get the widget to use all the images available in my galleries?

Thank you for your help.
TopBottom

Admins Online
There are   members online.
So-and-so has logged on!
%title%
%message%